Wireless

Wireless 第51回「Catalyst9800-CLをVMware ESXiに導入してみた(後編)」

こんにちは。TEと申します。

前回に続きまして、仮想アプライアンスであるCatalyst9800-CLのVMware ESXiへの導入検証について紹介いたします。今回の後編では、C9800-CLの初期セットアップ〜APをJoinさせるところまでの内容をご紹介いたします。前編をまだご覧頂けていない方は、お手数ですが、こちらからご覧ください。

 

検証環境と今回の設定箇所についてです。

前回で既にVMware ESXiに仮想マシンとしてC9800-CLを作成しましたので、今回はC9800-CLの初期セットアップとC9105AXI-QのJoinさせる部分を構築したいと思います。

 

では、まずはC9800-CLのCLIにアクセスします。

VMware ESXiにログインできたらナビゲータの 仮想マシン>C9800CLのウィンドウにてパワーオン >CLI画面をクリックし、完全に起動するまで待機します。

※CLI画面に「Would you like to enter the initial configuration dialog? [yes/no]:」が表示されるまで待機します。

CLI画面にて、C9800-CLの管理画面にアクセスするための設定を行っていきます。今回は、以下の赤字部分のコマンドを入力しました。

-----------------------------------------------------------------

Would you like to enter the initial configuration dialog? [yes/no]: no

Would you like to terminate autoinstall? [yes]: no

WLC>enable

WLC#conf t

WLC(config)#username cisco privilege 15 secret Cisco123 #ユーザ名、パスワードの設定

WLC(config)#vlan 90 #コントローラ管理用VLANの作成

WLC(config-vlan)#exit

WLC(config)#interface vlan 90

WLC(config-if)#ip address 10.47.90.99 255.255.255.0 #コントローラ管理用VLANのIPアドレスの設定

WLC(config-if)#no shutdown

WLC(config-if)#exit

WLC(config)#interface GigabitEthernet2  

WLC(config-if)#switchport mode trunk #ワイヤレス管理用インターフェイスをトランクに設定

WLC(config-if)#switchport trunk native vlan 90

WLC(config-if)#no shutdown

WLC(config-if)#exit

WLC(config-if)#ip route 0.0.0.0 0.0.0.0 10.47.90.254 #デフォルトルートの設定

 

WLC(config)#exit

WLC#write memory

Building configuration... [OK]

-----------------------------------------------------------------

 

続いて、コントローラ管理IPからゲートウェイに対して疎通確認を行います。

以下の赤字コマンドを入力し、出力結果に「!」が出ていればOKです。

-----------------------------------------------------------------

WLC#ping 10.47.90.254

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.47.90.254, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 3/3/3 ms

-----------------------------------------------------------------

 

設定用PCのWebブラウザからC9800-CLの管理画面へアクセスします。

ユーザ名、パスワードは先ほどコマンドで設定したものを入力し、ログインします。

すると、初期セットアップウィザードが表示されますが、基本的には物理アプライアンスと同様となりますので詳細な説明は割愛させて頂きます。今回の設定例につきましては、以下の画像をご参照ください。また、韋駄天アカウントをお持ちの方は、ログイン後に以下のC9800シリーズ物理アプライアンスの初期設定ガイドを併せてご参照ください。

https://www.idaten.ne.jp/portal/page/in/DIS/cisco2/technology/03/3103.pdf

 

物理アプライアンスの設定と異なる点としまして、仮想コントローラではAPがJoinするための証明書の設定が必要となりますので、必ず以下の画面で任意のパスワードを入力し、設定を行ってください。設定を行わない場合はAPがC9800-CLにJoinできなくなりますので、ご注意ください。

最後に設定内容に問題無ければ、初期セットアップウィザードを終了します。

続いて、C9105AXI-QのAPをC9800-CLと同じVLAN90に接続します。その後、再度設定用PCのブラウザでC9800-CL管理画面にログインし、アクセスポイントが1と表示されている事が確認できれば、APのJoinが完了となります。

なお、今回C9105AXI-QはC9800-CLと同じセグメントに接続しましたが、異なるセグメントに接続する場合は、そのままだとC9105AXI-QはJoinできない為、DHCPオプション43と60を使用して接続するコントローラのIPアドレスをAPに通知するか、C9105AXI-QにてスタティックでC9800-CLのIPなどを設定してあげる必要があります。DHCPオプションでの通知方法につきましては、以下のメーカードキュメントにてご確認ください。

https://www.cisco.com/c/en/us/support/docs/wireless-mobility/wireless-lan-wlan/97066-dhcp-option-43-00.html

 

また、韋駄天アカウントをお持ちの方は、ログイン後に以下のガイドにてDHCPオプションでの通知およびスタティックでのコントローラIP指定方法をご覧頂けます。

https://www.idaten.ne.jp/portal/page/in/DIS/cisco2/technology/03/3119.pdf

 

設定は以上となります。

 

如何でしたでしょうか。VMware ESXiについてあまり詳しくない方は少し難しく思われるかもしれませんが、C9800CLの仮想マシンを作成してしまえば、そのあとの設定方法はほとんど物理アプライアンス版の設定と変わりありません。

また、機能においても今回ご紹介したプライベートクラウド版に関しましては、制限はありませんので安心してご利用頂けるかと思います。

 

 最後までご覧頂きありがとうございました。

 引き続きよろしくお願いいたします。

カタログDL等、iDATEN(韋駄天)ログインが必要なコンテンツがございます。
必要に応じて、ログインしてご利用ください。
iDATEN(韋駄天)のご利用に関してご不明点があるお客様は こちら をお読みください。

Ciscoの記事